nginx

Mimo Janra

Самец :)
Награды
4
Приветствую всех, необходима помощь с настройкой, вместо открытия php файлов предлагает их скачать, хотя php5-fpm работает нормально и в конфигах подключен
 

Mimo Janra

Самец :)
Награды
4
..., хотя php5-fpm работает нормально ...
По-моему, это утверждение - ложно.
не исключено и это, ни когда не работал с nginx, а только с апачем.
Но service php5-fpm start запускает его.
Только у меня теперь другая проблема, кто может конфиг nginx посмотреть опытным взглядом?
Код:
user www-data;
worker_processes  1; # Ставим число по количеству ядер

timer_resolution 100ms;
worker_rlimit_nofile 8192;
worker_priority -5; #Увеличитвваем приоритет

error_log  /var/log/nginx/error.log;
pid        /var/run/nginx.pid;
events {
    worker_connections  1024;
}
http {
    include       /etc/nginx/mime.types;
    access_log	/var/log/nginx/access.log;

    sendfile        on;
    keepalive_timeout  65;
    tcp_nodelay        on;

    gzip	on;
    gzip_min_length	1100;
    #gzip_disable	"msie6";  #Быстрее, но работает только на новых версиях nginx
    gzip_disable "MSIE [1-6]\.(?!.*SV1)";
    gzip_proxied	any;
    gzip_comp_level	4;
    gzip_types 		text/plain text/css application/x-javascript text/xml application/xml application/xml+rss text/javascript;
    gzip_vary		on;

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}
Установка и настройка: Nginx + php5-fpm / Хабрахабр по этой инструкции делал и теперь он вообще не запускается :D
 

iglov

Сотрудник ИС
Факт висящего в процессах демона не говорит о корректности его работы.
Возможно у Вас нет пользователя www-data? Что пишут в логах нынче?
 

Mimo Janra

Самец :)
Награды
4
HTML:
server {
    charset utf-8;
    client_max_body_size 128M;

    listen 80; ## listen for ipv4
    #listen [::]:80 default_server ipv6only=on; ## listen for ipv6

    server_name mysite.local;
    root        /path/to/basic/web;
    index       index.php;

    access_log  /path/to/basic/log/access.log;
    error_log   /path/to/basic/log/error.log;

    location / {
        # Redirect everything that isn't a real file to index.php
        try_files $uri $uri/ /index.php?$args;
    }

    # uncomment to avoid processing of calls to non-existing static files by Yii
    #location ~ \.(js|css|png|jpg|gif|swf|ico|pdf|mov|fla|zip|rar)$ {
    #    try_files $uri =404;
    #}
    #error_page 404 /404.html;

    location ~ \.php$ {
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root/$fastcgi_script_name;
        fastcgi_pass   127.0.0.1:9000;
        #fastcgi_pass unix:/var/run/php5-fpm.sock;
        try_files $uri =404;
    }

    location ~ /\.(ht|svn|git) {
        deny all;
    }
}
с такой конфой все хорошо
 
Сверху