1. Всем пользователям необходимо проверить работоспособность своего электронного почтового адреса. Для этого на, указанный в вашем профиле электронный адрес, в период с 14 по 18 июня, отправлено письмо. Вам необходимо проверить свою почту, возможно папку "спам". Если там есть письмо от нас, то можете не беспокоиться, в противном случае необходимо либо изменить адрес электронной почты в настройках профиля , либо если у вас электронная почта от компании "Интерсвязь" (@is74.ru) вы им долго не пользовались и хотите им пользоваться, позвоните в СТП по телефону 247-9-555 для активации вашего адреса электронной почты.
    Скрыть объявление

RouterOS

Тема в разделе "Сетевое оборудование", создана пользователем PowerUser, 3 июл 2012.

  1. PowerUser

    PowerUser Ословед

    Репутация:
    456
    PowerUser, 3 июл 2012
    Имеется:
    1. Железка Mikrotik RB 750
    2. Чудный провайдер "Интерсвязь"

    Подключаем роутер в сеть провайдера:
    Код:
    [root@MikroTik] > interface ethernet print detail 
    Flags: X - disabled, R - running, S - slave 
     0 R  name="ether1_IS" mtu=1500 l2mtu=1600 mac-address=D4:CA:6D:3B:AC:9B arp=enabled auto-negotiation=yes full-duplex=yes speed=100Mbps 
    





    Пытаемся получить ip по dhcp:
    Код:
    [root@MikroTik] > ip dhcp-client print detail     
    Flags: X - disabled, I - invalid 
     0    interface=ether1_IS add-default-route=yes default-route-distance=0 use-peer-dns=yes use-peer-ntp=yes status=bound address=10.50.42.62/19 
    dhcp-server=10.50.32.1  primary-dns=78.29.2.21 secondary-dns=78.29.2.22 primary-ntp=10.100.12.14 secondary-ntp=10.100.12.15 expires-after=15m38s 
    





    Получаем маршруты в сеть, но НЕ получаем default gateway:
    Код:
    [root@MikroTik] > ip route print detail 
    Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
    
    
     1 ADS  dst-address=5.79.128.0/17 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
     2 ADS  dst-address=10.48.0.0/12 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
     3 ADC  dst-address=10.50.32.0/19 pref-src=10.50.42.62 gateway=ether1_IS gateway-status=ether1_IS reachable distance=0 scope=10 
    
    
     4 ADS  dst-address=10.100.12.0/24 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
     5 ADS  dst-address=10.128.0.0/13 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
     6 ADS  dst-address=31.207.128.0/17 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
     7 ADS  dst-address=37.140.0.0/17 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
     8 ADS  dst-address=78.29.0.0/23 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
     9 ADS  dst-address=88.206.0.0/17 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
    10 ADS  dst-address=95.129.163.56/29 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
    11 ADS  dst-address=109.191.0.0/16 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
    12 ADS  dst-address=176.226.128.0/17 gateway=10.50.32.1 gateway-status=10.50.32.1 reachable via  ether1_IS distance=0 scope=30 target-scope=10 vrf-interface=ether1_IS 
    
    
    13 ADC  dst-address=192.168.0.0/24 pref-src=192.168.0.35 gateway=Int gateway-status=Int reachable distance=0 scope=10 
    





    Смотрим логи:
    Код:
    [root@MikroTik] > log print where buffer=memory  
    00:40:51 dhcp,debug,state debug: dhcp-client on ether1_IS entering <selecting...> state 
    00:40:52 dhcp,debug,packet debug: dhcp-client on ether1_IS sending discover with id 2833397354 to 255.255.255.
    255 
    00:40:52 dhcp,debug,packet debug:     flags = broadcast 
    00:40:52 dhcp,debug,packet debug:     ciaddr = 0.0.0.0 
    00:40:52 dhcp,debug,packet debug:     chaddr = D4:CA:6D:3B:AC:9B 
    00:40:52 dhcp,debug,packet debug:     Msg-Type = discover 
    00:40:52 dhcp,debug,packet debug:     Client-Id = 01-D4-CA-6D-3B-AC-9B 
    00:40:52 dhcp,debug,packet debug:     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-
    Server,NTP-Server 
    00:40:52 dhcp,debug,packet debug:     Host-Name = "MikroTik" 
    00:40:52 dhcp,debug,packet debug: dhcp-client on ether1_IS received offer with id 2833397354 from 10.50.32.1 
    00:40:52 dhcp,debug,packet debug:     hops = 1 
    00:40:52 dhcp,debug,packet debug:     flags = broadcast 
    00:40:52 dhcp,debug,packet debug:     ciaddr = 0.0.0.0 
    00:40:52 dhcp,debug,packet debug:     yiaddr = 10.50.42.62 
    00:40:52 dhcp,debug,packet debug:     giaddr = 10.50.32.1 
    00:40:52 dhcp,debug,packet debug:     chaddr = D4:CA:6D:3B:AC:9B 
    00:40:52 dhcp,debug,packet debug:     Msg-Type = offer 
    00:40:52 dhcp,debug,packet debug:     Server-Id = 10.50.32.1 
    00:40:52 dhcp,debug,packet debug:     Address-Time = 1800 
    00:40:52 dhcp,debug,packet debug:     Subnet-Mask = 255.255.224.0 
    00:40:52 dhcp,debug,packet debug:     Classless-Route = 0C-0A-30-0A-32-20-01-18-0A-64-0C-0A-32-20-01-17-4E-1D-
    00-0A-32-20-01-1D-5F-81-A3-38-0A-32-20-01-0D-0A-80-0A-32-20-01-11-1F-CF-80-0A-32-20-01-11-58-CE-00-0A-32-20-01
    -11-25-8C-00-0A-32-20-01-11-05-4F-80-0A-32-20-01-11-B0-E2-80-0A-32-20- 
    00:40:52 dhcp,debug,packet debug: 01-10-6D-BF-0A-32-20-01 
    00:40:52 dhcp,debug,packet debug:     [B]Router = 10.50.32.1 [/B]
    00:40:52 dhcp,debug,packet debug:     Domain-Server = 78.29.2.21,78.29.2.22 
    00:40:52 dhcp,debug,packet debug:     NTP-Server = 10.100.12.14,10.100.12.15 
    00:40:52 dhcp,debug,state debug: dhcp-client on ether1_IS entering <requesting...> state 
    00:40:52 dhcp,debug,packet debug: dhcp-client on ether1_IS sending request with id 2833397354 to 255.255.255.2
    55 
    00:40:52 dhcp,debug,packet debug:     flags = broadcast 
    00:40:52 dhcp,debug,packet debug:     ciaddr = 0.0.0.0 
    00:40:52 dhcp,debug,packet debug:     chaddr = D4:CA:6D:3B:AC:9B 
    00:40:52 dhcp,debug,packet debug:     Msg-Type = request 
    00:40:52 dhcp,debug,packet debug:     Server-Id = 10.50.32.1 
    00:40:52 dhcp,debug,packet debug:     Address-Request = 10.50.42.62 
    00:40:52 dhcp,debug,packet debug:     Client-Id = 01-D4-CA-6D-3B-AC-9B 
    00:40:52 dhcp,debug,packet debug:     Parameter-List = Subnet-Mask,Classless-Route,Router,Static-Route,Domain-
    Server,NTP-Server 
    00:40:52 dhcp,debug,packet debug:     Host-Name = "MikroTik" 
    
    Вроде бы, если судить по логам Router = 10.50.32.1 на в итоге [attachment=16351:Bag.jpg]






    Помогите, может кто-то уже наступал на эти грабли, или я что-то упустил существенное. Гугл ничего не возвращает по этому поводу, похоже я один такой счастливый. Саппорт провайдера в 3 голоса говорит, что у них все работает и вообще все классно. Ноутбук с виндой getaway радостно получает. :angry:
     
    #1
  2. Sedrick

    Sedrick

    Репутация:
    9.891
    Sedrick, 4 июл 2012
    Код:
    ip route add dst-address=78.29.2.0/23 gateway=10.51.32.1
    , а лучше СразуИнтернет.
    upd. Плохо гуглил, кстати. Для билайна (или корбины, не помню) описаны проблемы использования микротиков.
    upd2.
    Код:
    /system scheduler
    add name=schedule1 on-event=script1 policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
        start-time=startup
    add interval=1d name=schedule2 on-event=script1 policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
        start-date=jun/29/2012 start-time=06:00:00
    /system script
    add name=script1 policy=\
        ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
        source=":local NewGatewayIp [/ip route get [find dst-address=78.29.0.0/23]\
        \_gateway];\r\
        \n/ip route set [find dst-address=78.29.2.0/23] gateway=\$NewGatewayIp;\r\
        \n:delay 3\r\
        \n:local NewVpnIp [:resolv \"unlim.is74.ru\"];\r\
        \n/interface pptp-client set pptp-out1 connect-to=\$NewVpnIp;"
     
    #2
  3. PowerUser

    PowerUser Ословед

    Репутация:
    456
    PowerUser, 4 июл 2012
    Это все понятно, так и работало на шлюзе с фрей. Только вот ИС периодический меняет адресацию сети => роут перестает работать вместе и интернетом. Причем о смене адресации они не уведомляют.

    "Сразу интернет" отпадает, договор на юр. лицо. Также не хотят давать pppoe. Из решений предлагают "выделенную линию", как я понял аналог "сразу-интернет", но стоит денег, попахивает навязанной услугой :D. Оно бы и фиг с ним, но организация бюджетная, запаришься объяснять увеличение стоимости договора.
    Находил подобную тему, там все ссылаются на некую инструкцию, которая лежит на неком сайте, но ее там уже нету. за давностью постов видать удалили, так что саму инструкцию посмотреть не удалось.
    upd2.
    Пока сделал роут на интерфейс, вроде работает.... скриты не очень хочется городить.

    upd но за скрипт большое спасибо.
     
    #3
  4. Sedrick

    Sedrick

    Репутация:
    9.891
    Sedrick, 4 июл 2012
    Не будет работать никаким роутом на интерфейс. Не нравятся скрипты — меняй каждый раз адрес шлюза вручную.
     
    #4
  5. PowerUser

    PowerUser Ословед

    Репутация:
    456
    PowerUser, 4 июл 2012
    Код:
    0 A S  0.0.0.0/0                          ether1_IS               100
    8 ADS  78.29.0.0/23                       10.50.32.1                0
    
    
    Код:
    [root@MikroTik] > ping unlim.is74.ru
    HOST                                     SIZE TTL TIME  STATUS
    78.29.3.155                                56  63 22ms
    78.29.3.155                                56  63 0ms
    
    ЧЯДНТ? =)
     
    #5
  6. Sedrick

    Sedrick

    Репутация:
    9.891
    Sedrick, 4 июл 2012
    Ага, и впн наверное работает?
     
    #6
  7. PowerUser

    PowerUser Ословед

    Репутация:
    456
    PowerUser, 4 июл 2012
    Вот впн пока нет возможности проверить :sorry:
     
    #7
  8. Sedrick

    Sedrick

    Репутация:
    9.891
    Sedrick, 4 июл 2012
    Вот, когда он не будет работать, пропиши роут из моего первого сообщения, можешь указать шлюзом интерфейс (тут всё-таки похоже работает). Инструкцию для корбина/билайн не удаляли, просто ссылка изменилась.

    upd. Действительно работает, когда настраивал первый раз — нет, но видимо я тогда где-то ошибся. http://wiki.mikrotik.com/wiki/Manual:IP/Route#Routes_with_interface_as_a_gateway
     
    #8
  9. PowerUser

    PowerUser Ословед

    Репутация:
    456
    PowerUser, 4 июл 2012
    Да это если честно больше политический вопрос, сделать чтобы работал интернет я могу большИм кол-ом способов. Меня больше интересует, почему не работает штатными средствами "из коробки", микротик не понимает или ИС не то раздает. Проще говоря где я ошибся, при выборе провайдера или при выборе железки...
     
    #9
  10. Sedrick

    Sedrick

    Репутация:
    9.891
    Sedrick, 4 июл 2012
    #10
  11. PowerUser

    PowerUser Ословед

    Репутация:
    456
    PowerUser, 4 июл 2012
    Печальная история... жаль чел версию ос не озвучил. Подождем пока исправят.
     
    #11
  12. Sedrick

    Sedrick

    Репутация:
    9.891
    Sedrick, 4 июл 2012
    Не стоит, вряд ли это кого-то интересует.
     
    #12
  13. PowerUser

    PowerUser Ословед

    Репутация:
    456
    PowerUser, 4 июл 2012
    #13
  14. Sedrick

    Sedrick

    Репутация:
    9.891
    Sedrick, 4 июл 2012
    121 — это Classless Static Route Option, а 122 — CableLabs Option. Видимо в вики опечатка.
     
    #14
  15. Larson

    Larson Ословед

    Репутация:
    5.235
    Larson, 30 мар 2013
    Есть ли тут пользователи MikroTik RouterOS x86?
    Есть вопросы по этой теме, как у любого новичка...
     
    #15
Загрузка...